DELPHI盒子
!实时搜索: 盒子论坛 | 注册用户 | 修改信息 | 退出
检举帖 | 全文检索 | 关闭广告 | 捐赠
技术论坛
 用户名
 密  码
自动登陆(30天有效)
忘了密码
≡技术区≡
DELPHI技术
移动应用开发
Web应用开发
数据库专区
报表专区
网络通讯
开源项目
论坛精华贴
≡发布区≡
发布代码
发布控件
文档资料
经典工具
≡事务区≡
网站意见
盒子之家
招聘应聘
信息交换
论坛信息
最新加入: cetacean66
今日帖子: 16
在线用户: 11
导航: 论坛 -> 移动应用开发 斑竹:flyers,iamdream  
作者:
男 he_19_79 (he) ▲▲▲▲△ -
注册会员
2021/6/27 16:49:08
标题:
android:targetSdkVersion="%targetSdkVersion%"在哪里设置这个参数? 浏览:412
加入我的收藏
楼主: 用Delphi 10.3做了一个简单的APP, 但在Android 11下闪退, 在Android 10及以下(用32位的, 用64位时经常有显示不可控的错误)都非常正常稳定, 很迷惑.

刚查了下, 想知道%targetSdkVersion%在什么地方设置? 明明是Android 11的手机,出来的结果是28, 不是30, 这肯定不正常.
----------------------------------------------
-
作者:
男 keymark (嬲) ▲▲△△△ -
注册会员
2021/6/28 10:52:58
1楼: 官方有说支持11?按此在新窗口浏览图片  用java吧。
----------------------------------------------
git config --global alias.co 'clone --recurse-submodules'
git config --global alias.up 'submodule update --init --recursive'
懒鬼提速
http://qalculate.github.io/downloads.html
https://www.cctry.com/
作者:
男 shileizi (sl) ★☆☆☆☆ -
普通会员
2021/6/29 15:39:56
2楼: 看这个帖子 https://www.cnblogs.com/kinglandsoft/p/14283134.html
----------------------------------------------
-
作者:
男 he_19_79 (he) ▲▲▲▲△ -
注册会员
2021/7/6 16:00:38
3楼: 万分感谢楼上.

有问题还真的是2CCC有帮助, 用了楼上连接的方法, 把20.0\lib\android\release中的文件2个文件替换后, 还真的不闪退了(64位的我还没试,只试了32位的), 也正常了. 

用10.3.3是没办法,而且是虚拟机中的控件的原因,加上这个Android程序比较小.

再次感谢shileizi(sl), 多谢!
----------------------------------------------
-
信息
登陆以后才能回复
Copyright © 2CCC.Com 盒子论坛 v2.1 版权所有 页面执行35.15625毫秒 RSS